» Diskussionsforum » Forum Bau-Finanzierung

Excel-Tool für Kreditabschätzung

6 Beiträge | letzte Antwort 18.4.2019 | erstellt 13.4.2019
Hallo zusammen!

Ich bin Techniker und habe mit dem Finanzwesen nichts am Hut - deshalb hab ich mir um ein Gefühl dafür zu bekommen, was Änderungen bei Kreditkonditionen wirklich bedeuten, ein Excel-Tool (ohne VBA-Makro) erstellt. Damit kann man in der aktuellen Version (1.1) fix verzinste, variabel verzinste und kombiniert verzinste Kredite mit beliebigen Parametern berechnen.

Konkret kann man Zinssätze, Laufzeiten, die monatliche fixe Rate, den Euribor mit einer einstellbaren jährlichen Steigerung, die Abrechnungsperiode und den Rückzahlungsbeginn, den Kreditbetrag und Nebenkosten sowie Sondertilgungen als Berechnungsgrundlage eintragen (die grau hinterlegten Zellen).

Ich hab die ursprünglich etwas komplizierten und langen Formeln etwas aufgeteilt und Zwischenergebnisse in ausgeblendeten Spalten berechnet - für die Nachverfolgung oder Wissbegierige vielleicht auch interessant.

Man sollte die Laufzeiten, das Aufnahmedatum und den Rückzahlungsbeginn der Abrechnungsperiode anpassen - damit die Berechnungen exakt sind (also zb 180 oder 183 Monate Laufzeit bei quartalsweiser Abrechnung und nicht 181 Monate). Sondertilgungen werden derzeit erst korrekt berechnet, sobald die Ratenzahlungen eingesetzt haben.

Der konkrete Nutzen für mich liegt darin einfach abschätzen zu können, was eine Änderung der Rate, Zinsen oder Laufzeit, etc. an Kostenänderung bewirkt. Die Vergleichbarkeit zB. bei einem geänderten Parameter ist - so glaube ich - recht gut.

Ich habe alle Berechnungen mit Online-Tools und konkreten Bankangeboten geprüft - ein kleiner Differenzbetrag zu den Bankangeboten ist zum Teil vorhanden, beträgt aber weniger als 0,25%.
Es gibt natürlich keinerlei Gewähr für die Richtigkeit der Ergebnisse!
Für Hinweise zu Fehlern und allen sonstigen Rückmeldungen wäre ich euch sehr dankbar!

Hier gibts das Excelfile auf Onedrive (*.xlsx): https://1drv.ms/x/s!Av5750ZoFFYEhLktoa2smQhF03iMvQ (würde euch empfehlen es herunterzuladen)

Grüße, Reinhard

 
14.4.2019 20:43
Wow, danke!
15.4.2019 9:45
Hallo Reinhard,

toll das Du Deine Arbeit mit uns teilst, Danke dafür! (Wollte Dir auch einen Stern geben aber das geht anscheinend bei dem ersten Beitrag nicht)

Das Excel gefällt mir sehr gut, da kann man nämlich schnell ausprobieren welche Änderungen bei den Konditionen/Bedienungen zu welchen Veränderungen bei der Gesamtbelastung führen.

Eines ist mir aufgefallen, in der Spalte Q sollte die Formel folgendermaßen angepasst werden:
von:
WENN(UND(H2>$C$3;H2<=$C$7);WENN(F2>0;RMZ(P2*$D$15;($C$7-H2+12*$D$15)/(12*$D$15);-L1;;$D$13););)
auf:
=WENN(UND(H2>$C$3;H2<=$C$7;G2>=$C$17);WENN(F2>0;RMZ(P2*$D$15;($C$7-H2+12*$D$15)/(12*$D$15);-L1;;$D$13););)

Dann wird auch der Rückzahlungsbeginn richtig berücksichtigt.

lg
Christoph

Edit:
Nochetwas ist mir aufgefallen, Spalte N stimmt bei mir bei den ersten Monaten nicht, nach Anpassung der Formel stimmen dann auch die ersten Monate:

=WENN(H5<=$C$3;WENN(F5>0;K4*$C$2*$D$15;);)
15.4.2019 10:18
Hallo Christoph,
danke für den Hinweis!

Ich habs so geändert:
=WENN(UND(H2>$C$3;H2<=$C$7;I2>0);WENN(F2>0;RMZ(P2*$D$15;($C$7-H2+12*$D$15)/(12*$D$15);-L1;;$D$13););)

Ich frag die Anzahl der gezahlten Raten hab, führt zum gleichen Ergebnis und grundsätzlich wäre es möglich einfach eine Rate auszusetzen, wenn man in der Spalte I einen 0er einträgt. Ich hab auch versucht einen möglichst einfachen nachvollziehbaren aufbau zu machen - die zwei Datumsangaben haben nur Auswirkung auf Spalte H und I.

Neue Version 1.2
https://1drv.ms/x/s!Av5750ZoFFYEhLkv8vCHYRhxX6idFw

Ich werd es abends nochmal ausführlich testen und kontrollieren - ich hab jetzt leider keine Zeit mehr.

Lg
Reinhard


15.4.2019 12:53


W4tler schrieb: Edit:
Nochetwas ist mir aufgefallen, Spalte N stimmt bei mir bei den ersten Monaten nicht, nach Anpassung der Formel stimmen dann auch die ersten Monate:

=WENN(H5<=$C$3;WENN(F5>0;K4*$C$2*$D$15;);)


 
Danke auch für den Hinweis, ich bin jetzt leider schon unterwegs und hab keine Zeit mehr - heute Abend oder morgen schau ich mir das an!

Lg
Reinhard
17.4.2019 0:43


W4tler schrieb: Edit:
Nochetwas ist mir aufgefallen, Spalte N stimmt bei mir bei den ersten Monaten nicht, nach Anpassung der Formel stimmen dann auch die ersten Monate:

=WENN(H5<=$C$3;WENN(F5>0;K4*$C$2*$D$15;);)


Ich hab nun Version 1.3 erstellt und diesen Fehler behoben:
https://1drv.ms/x/s!Av5750ZoFFYEhLky1R6vsjdpkdfj3A?e=UDVc61

So wie du es ausgebesserst hast, stimmt es nur für nachschüssig (was ja eh praktisch immer der Fall ist, aber ich wollte das Sheet halt möglichst universal haben :) ).

Ich hab es ähnlich gemacht, nur auch noch abgefragt, ob Vor- oder Nachschüssig (und ich hab Zwecks Übersichtlichkeit und Nachvollziehbarkeit noch eine Spalte für die fixen Raten eingebaut, die die Grundlage der Rate für die vorschüssige Berechnung liefert).

Weiters hab ich noch einen kleinen Fehler in Spalte K korregiert, jetzt funktionieren Sondertilgungen immer und nicht erst ab Beginn der Ratenzahlung.

Wenn weitere Fehler auffallen bitte unbedingt Bescheid geben - vielen Dank!

Grüße,
Reinhard


18.4.2019 16:56
Vielen Dank für die Sternchen :)

Ich hab jetzt Version 2 erstellt.
Hier zum Download (Version 2.1): https://1drv.ms/x/s!Av5750ZoFFYEhLk1lXqQigdSdB6tsw?e=XACqnR (ohne Gewähr auf Richtigkeit ;) )

Ich hab nochmals einige Formeln vereinfacht indem ich Zwischenergebnisse auf weitere Spalten aufgeteilt habe. Damit ist die Nachverfolgbarkeit auch wieder deutlich besser geworden!

Einige kleine Fehler hab ich noch gefunden und korrigiert.
Für die üblichen Situationen glaub ich sollte jetzt wirklich alles stimmen.

Wer noch Fehler findet, bitte Bescheid geben - Danke!

lg, Reinhard



Beitrag hinzufügen oder Werbung ausblenden?
Einloggen

 Kostenlos registrieren [Mehr Infos]

« Forum Bau-Finanzierung